
Introduction

Welcome to PixBuilder Studio!

PixBuilder Studio is a powerful and easy to use application for image creation, viewing
and manipulation. The program is ideal for working with digital photos. Also you can
create and open icons. The application run instantly, processes images up quickly and
with high quality. The work with layers is supported, multi-step undo is available, print
with preview and save with preview are also of use.
Features include resizing, rotating, text operations and many others. It works under
Windows 95, 98, Me, NT, 2000, XP, Vista and Windows7. The program has multilingual
interface.

The newest version of PixBuilder Studio is always available on our Web site:
http://www.wnsoft.com

Also you can visit PixBuilder Studio Forum:
http://www.picturestoexe.com/forums

http://www.wnsoft.com
http://www.picturestoexe.com/forums


Features

Supported formats
for read : BMP, PNG, JPG, GIF, TIFF, PCX, TGA, PSD, ICO
for write : BMP, PNG, JPG, GIF, TIFF, PCX, TGA, ICO

Work with layers;
Multi-step undo;
Levels, curves, color balance, brightness\contrast, rotate etc;
A big number of effects;
Save with preview;
Print with preview;



About Layers

An image can consist of several overlapping layers. The empty parts of a layer are
transparent which makes the underlying layers visible. Each layer can have its own size
and can be shifted with respect to the other layers. A level of transparency can be set
for each layer. Layers can be reordered by a user. A layer can be either bitmapped or
textual. Several layers can be selected in a group.

Designing different logical parts of an image on separate layers is a convenient
technique because it allows you to edit the whole image by editing separate layers or
turning them on/off.

The following topics are available:

Layers Panel

Grouping layers

"As Selection"

Layer Properties

Drop Shadow

Fast selection of an active layer

 



Layers Panel

The Layers Panel is needed for managing the layers. It shows the list of names of layers
ordered by their location from top to bottom. The layer in bold is the one currently
selected for editing. In order to select another layer, click on its name on the Layers
Panel.

A - group of layers,
B - textual layer,
C - selected layer,
D - invisible layer,
E - add a new layer,
F - add a new group of layers,
G - delete a layer or a group,
H - show properties of a layer or a group.

A context menu is also available for managing the layers.

PixBuilder Studio allows selecting several layers at once by holding down the Shift key
while clicking on the desired layer names. You can also do this by encircling the desired
layer names with a mouse.



Selecting several layers at once with a mouse.
 



Grouping layers

Select the layers you want to group and click Combine Layers on the user menu. As a
result, all textual layers become bitmapped and the text inside becomes no longer
available for editing.

 



"As Selection"

Applying "As Selection" on the user menu transforms the current layer according to the
following rule: the brighter the pixel, the more intensely it will be highlighted.

The results of applying "As Selection"
A-for a textual layer,
B-for a bitmapped layer.
 



Layer Properties

Clicking on "Layer Properties..." will open the window shown on Figure 1.

Fig. 1

The name of a layer and its transparency can be set here. The transparency of a layer
does not influence its Alpha-channel.

 



Drop Shadow

Every layer has an optional "Drop Shadow". When it is turned on, the layer casts a
shadow on the underlying layers. The use of this option changes neither the structure of
the layer itself nor the structure of the underlying layers.

When "Drop Shadow" is turned on, the following properties are available:

Color-the color of the shadow.
Angle-the angle of the imaginary source of light giving the shadow.
Distance-the distance to the shadow.
Size-the parameter showing the level of image blur. The bigger the number the
blurrier the image.

 



Fast selection of an active layer

Hold Ctrl down and right click on an image. The list of the layers existing at this point of
the image will appear.

 



About selection

If an active part of an image is selected, you can apply effects, filters, and other editing
tools exclusively to the selected area. The rest of the image will not change. A selected
area can be shaped using tools such as Rectangular Marquee, Elliptical Marquee, Lasso,
Magic Wand, as well as with the command Color Range.

The following topics are available:

Create a selected area using the tools

Create a selected area using Magic Wand

Create a selected area by color

Transform Selection

 



Create a selected area using the tools

Activate the required tool. When the mouse hovers above a selected area, a cursor

appears . In this case, the selection can be shifted. If at the same time you hold a

Ctrl key down, a cursor appears . In this case, the selection will be shifted together
with the selected area. When a Shift key is held down, a new selected area can be

added to the already existing one . When an Alt key is held down, a new selected

area can be subtracted from the already existing one .

 



Create a selected area using Magic Wand

Activate Magic Wand. Click on any pixel. The adjacent pixels of the same tint, or of the
same level of transparency, will be selected. Then nonadjacent pixels of similar color
can be added to the selected area.

Turn on the flag "All Layers" on the Tools Panel, so that pixels from all areas shown on
your monitor can be taken into the selected area. Turn off the flag "All Layers" on the
Tools Panel if you wish to take pixels only from the active layer.

Turn on the flag Antialiasing to make the border of the selected area smoother.

To change the range of colors available for the Magic Wand, insert a number from 0 to
255 into the field "Tolerance" on the Tools Panel, and then click again on the image.
Insert 0 to select only one color. To gradually increase or reduce the range of colors,
change the delay between mouse clicks. The higher this value, the bigger the range of
colors that are available for selection.

 



Create a selected area by color

The command "Color Range" ("Selection" -> "Color Range") allows selecting areas by
color or by range of glow.

The command "Color Range" chooses colors from all visible layers. Select a part of an
image to restrict the working area.

To preview the selected area, choose the "Selection" mode. To return to the whole
image, choose "Image" mode. Click on the image to choose the colors. New colors can
be added to the selected area by holding down the Shift key while clicking on the
selected area. Unwanted colors can be subtracted from the selected area by holding
down the Alt key while clicking on the selected area. Alternatively, you can click on the
dropper with + or - on the Color Range panel and then click on the image or the
preview window.

 



Transform Selection

The command "Transform Selection" only affects the selection frame, not the image.
Choose the command "Select -> Transform Selection".

To change the horizontal and vertical sizes of a selected area, drag the frame corner. To
change either the horizontal or vertical size, drag the frame border. Move only one
corner or border by holding down the Ctrl key.

To rotate a selected area, place the cursor close to the frame manipulator either from
inside or outside (the cursor will reappear as a two-sided arrow) and drag the cursor in
a circular fashion.

To save the changes, click the mouse twice inside the frame or click on the OK button
from the Tools Panel or press Enter. To cancel the transformation, click on the Cancel
button or press Esc.

 



Channels

To shape an image, PixBuilder Studio uses four channels (RGBA). Each channel is a
grayscale image containing information about the color component for which this
channel is responsible. The resulting RGBA image consists of Red, Green, and Blue
channels and an Additional channel containing information about the level of
transparency.

To see how the channels work, you may open a chromatic image and select one of the
channels on the Channels Panel. As a result, you will see only the image component
produced by the channel you selected.

Original Image
 

The image of the R-channel component.
 

The Channels Panel.
All channels are selected.
A - the select-all-channels button.

Only the R-Channel is selected.
 
 

To restore the full image, click on the select-all-channels button.

In some cases, it is necessary to adjust color only for a certain channel. To do so, work
on the channel of interest by selecting it on the Channels Panel.



The G-channel is selected for adjustment.
 



Color Adjusting

PixBuilder Studio includes tools for adjusting color, lightness (darkness), and contrast of
an image. The commands available for color adjusting are located in the Color
submenu.

The commands can be applied to all the active raster layers. If no area has been
selected, the command is applied to the entire layer. Otherwise, it is applied only to the
selected area.

The following topics are available:

Brightness\Contrast

Color Balance

Levels

Auto Levels

Auto Contrast

Curves

Color/Saturation

Grayscale

Invert

Fill

 



Brightness\Contrast

The dialog for brightness\contrast adjustment can be called by clicking on "Colors ->
Brightness\Contrast" on the user menu.

This procedure is used to make the colors of an image darker, brighter, and more or
less clear.

Original Image The image after adjusting.
 



Color Balance

The Color Balance command lets you adjust the color balance of an image by shifting
the colors between complementary pairs of the primary RGB color values and secondary
CMY color values.

The dialog for Color Balance adjustment can be called by clicking on "Colors -> Color
Balance".

For example, if you want to tone down the red in a photo, you can shift the color values
from red to cyan. You can also change the hue values to change the colors used in an
image.

 



Levels

The dialog for adjusting levels can be started by clicking on "Colors -> Levels" on the
user menu.

You can do one of the following:

To increase brightness of the light colors and contrast, move the "Input Level"
marker (white) to the left. The marker showing the level of intermediate colors
(between dark and light) will shift as well. Adjust its position manually if needed.
To make dark colors darker, move marker "Input Levels" (black) to the right. The
marker showing the level of intermediate colors will shift as well. Adjust its position
manually if needed.
To adjust the level of intermediate colors independently, use the middle marker
"Input Levels".
To reduce contrast of an image and lighten it, move the "Output Levels" marker
(black) to the right.
To reduce contrast and darken an image, move the white marker "Output Levels" to
the left.

 



Auto Levels

This option is used for auto-leveling of an Input Level value for each of the
monochromatic RGB channels.

 



Auto Contrast

This option is used for auto-leveling of the entire RGB channel.

 



Curves

The dialog for adjusting curves can be started by clicking on "Colors -> Curves" on the
user menu.

A. Highlights
B. Colors
C. Shadows
D. Adjust a curve by adding points
E. Draw a curve with a pencil
F. Set a black point
G. Set a gray point
H. Set a white point

The dialogs for adjusting curves and for adjusting levels allow you to deal with the
entire color range. Unlike the dialog for adjusting levels, which includes only three
parameters (the level of white, the level of black, and gamma), the dialog for adjusting
curves gives you the opportunity to set an arbitrary number of points within the entire
color range of an image. You may also use the Curves dialog for precise adjustment of
the channels. You can save the settings you used during your work or upload previous
settings.

When the Curves dialog opens, the color range is shown as a diagonal line. The
horizontal axis shows the value for pixels of an original image (Input Levels), while the
vertical axis shows the new values (Output Levels).

 



Color/Saturation

The dialog for adjusting the color/saturation can be started by clicking on "Colors ->
Color/Saturation" in the user menu.

The Color/Saturation command is used to adjust the color and saturation of a single
monochromatic channel or of an entire image.

When the option "Master" in the window "Color" is chosen, the process of adjusting
affects all colors in an image. When a previously set color range is chosen, a manual
marker and eyedropper become accessible.

A color range, which depends on the Color, Saturation, and Lightness values, can be
narrowed or expanded.

 



Grayscale

To access this command, click on "Colors - Grayscale".

The Grayscale mode is a mode that uses up to 256 variations of gray to produce an
image. Every pixel of an image has a value representing brightness, ranging from 0
(black) to 255 (white).

 



Invert

To access this command, click on "Colors -> Invert" on the user menu.

The "Invert" command inverts colors in an image. When you apply the "Invert"
command to an image, the brightness value for each pixel in an image will be converted
to the inverse value in the scale consisting of 256 colors. For example, for a certain
pixel, a value of 255 will be converted to 0, and for another pixel a value of 5 will be
changed to 250.

 



Fill

To fill a selected area or an entire layer, do the following:

Choose a foreground or background color.
Select the area you want to fill. To fill an entire layer, select the layer in the Layers
panel.
Click on "Colors - Fill" on the user menu to fill a selection or layer. A dialog box will
appear in which you can choose the color.

The following colors are available: White, Foreground Color, Background Color,
Transparent and any color that you can choose from the dialog box.

Click on the OK button to complete the procedure.

 



Drawing

Drawing takes place on a selected layer. If several layers are selected, drawing takes
place on the layer that is placed highest on the Layers Panel. Drawing is allowed on the
entire layer if a working layer does not have a selected area. If there is a selected area,
the drawing is allowed only within this area.

To draw with the foreground color, hold down the left button of the mouse. To draw
with the background color, hold down the right button. To switch to the eyedropper,
hold down the Alt button and click on the image.

The following effects are available:

Set of brushes

Color Fill

Create a text layer

Fill with a gradient color

Create/edit a gradient

Change a color

Clone Stamp

 



Set of brushes

The Tools Panel has a set of brushes for the Brush, Pencil, Erase, Replace Color, Clone
Stamp, and Healing Brush tools.

A - a set of brushes
B - the size of the current brush
C - create a brush
D - edit the current brush
E - delete the current brush

The size of the current brush can be changed using the keys "[" and "]".

The key for creating a brush and the key for editing the current brush launch a dialog
which allows the user to make necessary brush settings.

Diameter is the width of a brush (varies from 1 to 1000 pixels).

Hardness is the value given in percentage of a brush diameter (varies from 0 to
100%). It determines the size of a nontransparent trace of a brush.

Angle is the angle of a brush slop.

Roundness. The bigger the value, the closer the shape of a brush trace to a circle. The
brush leaves a round trace when the value of roundness is 100, and a line when the
value is 0.

Spacing. The bigger the value, the bigger the distance between the traces of a brush.



 



Color Fill

The Color Fill tool is used for replacing an original color with a major color by filling
areas of similar color. The value of the Tolerance parameter is taken into account. The
bigger this value, the wider the color range that will be replaced by the Color Fill tool.
The tool does not require selecting a working area.

If the "All Layers" flag is turned on, the Color Fill tool fills the areas of an active layer
with the colors found on all layers visible at the moment (not only with those on the
active layer).

 



Create a text layer

The Text tool is used for creating a text layer. Selecting "Text tool" from the user menu
starts the dialog of a text entry.

A - the text format tools
B - the button for choosing text color
C - the button for loading the texture of the text
D - the button for loading text
E - the button for saving changes to the text
F - the Cancel button

The text editing dialog allows saving the text for later use in other images and
uploading previously saved text.

The Texture dialog is started by pressing the button for uploading text.

All the changes will be applied after pressing the OK button.

 



Fill with a gradient color

A gradient color is a smooth color transition between at least two colors.

The Gradient tool is used for coloring an image simply by dragging a cursor. After every
dragging, a new gradient will be applied to a layer.

To use the Gradient tool, go through the following steps:

Select or create a layer.
Select an area on a layer. Otherwise, a gradient will fill the entire layer.
Activate the Gradient tool.
Chose a gradient type on the settings panel.
Chose one of the following gradient styles: Linear, Radial, Angular, Reflected, or
Diamond.
To obtain a linear gradient, drag the cursor from one side of a selected area to the
other. To obtain any other type of a gradient, drag the cursor from the center of a
selected area to its side.

Gradient settings
A - a type of gradient
B - a style of gradient
 

Gradient types.
 

Gradient styles.
A - Linear gradient
B - Radial gradient
C - Angle gradient
D - Reflected gradient
E - Diamond gradient

Drag the cursor over a large distance to obtain a hardly noticeable color transition, or
over a short distance to obtain a sharp color transition.



 



Create/edit a gradient

PixBuilder Studio allows you to create and edit gradients.

A - the button for editing the current gradient
B - the button for creating a gradient
C - the button for deleting the current gradient

Pressing the button for editing or for creating a gradient starts the dialog for editing a
gradient.

 

The key points panel.
A - key points
B - the current key point
C - the points corresponding to the center of a color transition

A gradient consists of a set of key points, between which a color transition occurs. A
color and a position on a gradient can be set for each point (varies from 0 to 100%).



Left-click on the Key Points panel to create a key point. To delete a point, pull it out of
the working area.

The points corresponding to the center of a color transition lie between two neighboring
key points. They can be shifted either to the left or the right.

The result of shifting a color transition center.
 



Change a color

The Color Change tool is used for changing the color of pixels.

The result of color change.
 



Clone Stamp

The Clone Stamp tool is used for taking a fragment of an image for later reuse on the
same image. The tool can also be used to create duplicates of fragments among layers.
The Clone Stamp tool is used for duplicating an object or removing a defect from an
image.

Because you can use any brush tip with the Clone Stamp tool, you have a lot of control
over the size of the area you clone.

 



Effects

To access the available effects use the "Effects" submenu.

Effects are applied to all selected layers. If there is a text layer among those selected, it
should be converted to a bitmapped format. If a layer does not have a selected area,
the effect will be applied to the entire area of the layer. Otherwise, it will be applied to
the selected area only.

The following effects are available:

Dithering

Quick Blur

Gaussian Blur

Quick Sharp

Sharpness

Emboss

Unsharp Mask

Customized Matrix

 



Dithering

To be able to use a palette with a limited number of colors, the number of colors used to
form an image must be restricted. To obtain a color needed for an image that is not in
the palette, you may mix available colors to obtain a desired color.

To start dithering, run the dialog by pressing "Effects -> Dithering" on the user menu.

In this dialog you can choose a palette preset. The following presets are available:

The "Adaptive" option forms a palette, the use of which would minimize image
distortions.



After the palette is chosen and adjusted, the image will be adopted to it through
dithering.

 



Quick Blur

The Quick Blur command (Effects -> Quick Blur) is used for blurring an image. The
command has no parameters.

The command is used to eliminate distortions due to sharp color transitions that may
occur in an image. The Quick Blur smoothes color transitions by averaging the pixel
color around the edges of lines and shaded areas.

An image processed with the Quick Blur Effect.
 



Gaussian Blur

The Gaussian Blur effect (Effects -> Gaussian Blur...) uses the Gaussian algorithm by
applying a convolution matrix to each pixel. The size of a matrix is determined by the
value set by a user.

 



Quick Sharp

The Quick Sharp command (Effects -> Quick Sharp) is used to make an image sharper.
The command has no parameters and is used to highlight a selection to improve its
clarity.

An image processed with the Quick Sharp effect.
 



Sharpness

The Sharpness command (Effects -> Sharpness) is used to make a color transition
sharper and the edges of it more discernible. The level of sharpness can be set by a
user in the slide bar.

 



Emboss

The Emboss command is used to make a selection look embossed or stamped. It does
so by converting the color of a selection to gray while edges of this selection remain the
original color. Parameters include embossing angle (varies from -180- for a concave up
image to +180- for a concave down image), height, and percentage of the amount of
color within the selection (from 1% to 400%).

The Emboss dialog starts by clicking on "Effects -> Emboss" on the user menu.

 

An image processed with the Emboss effect.
 



Unsharp Mask

The Unsharp Mask command is used to find the areas in an image where substantial
color transitions occur, and to sharpen them. The command can be used to adjust the
contrast of a specific edge detail and produce light and dark lines from both sides of an
edge to emphasize it and create an illusion of a sharper image.

The Unsharp Mask dialog starts by clicking on "Effects -> Unsharp Mask" on the user
menu.

 



Customized Matrix

The Customized Matrix dialog starts by clicking on "Effects -> Customized Matrix" on
the user menu.

In this dialog, you can choose one of 22 available presets or set your own 5x5 matrix.
There is an option to save the matrix for later use with other images.

 



Mask Mode

When you select a part of an image, the remaining area is "masked" or protected from
editing. By creating a mask, you isolate an area of an image and protect it from
applying color changes, filters, or other effects. The Masks are used for complex image
editing such as gradually applied color changes or filter effects.

The Mask mode is needed for creating and editing selections of a sophisticated shape.
To enter the Mask mode, press the button in the lower left corner of the Channels Panel.

In this mode, the current selection transforms to a new layer (a mask) in which you can
apply the tools in the same way you would apply them on a regular layer. Instead of the
Channels Panel, the Mask Panel will appear.

The Mask Panel.
A - a selection transformed to a mask
B - other masks
C - the button for creating a mask
D - the button for deleting a mask
E - the button for exiting the Mask Mode

After pressing the button for exiting the Mask Mode, the mask becomes a regular
selection again.

An example of working with the Mask Mode is given below:

1. Using any selection tool, select the part of the image that you want to change.

2. Click on the Mask Mode button in the Channels Panel.

The area outside of the selection becomes overlaid and no longer available for editing.
The selected area remains available for editing. By default, the Mask Mode colors the
protected area with a red overlay.



Making selections in the Standard mode and in the Quick Mask mode.
A - The standard mode.
B - The Mask Mode.
C - Selected pixels appear white in the mask thumbnail.
D - Red overlay shows the protected area outside the selection. The unselected pixels appear
black in the mask thumbnail.

3. To edit the mask, select a drawing tool from the Tools panel.

4. Draw with white to select a larger area of an image (the overlay will be removed
from the areas painted with white). To de-select areas, draw over them with black (the
overlay will cover the areas painted with black). Drawing with gray or another color
creates a semitransparent area, which can be used for dealing with blur or antialiasing
effects. (Semitransparent areas may not appear selected when you exit the Mask Mode,
but, in fact, they are.)



Drawing in the Mask Mode
A - The original selection in the Mask Mode with a red mask color.
B - Drawing with white in the Mask Mode extends the selected area.
C - Drawing with black in the Mask Mode subtracts from the selected area.

5. Exit the Mask Mode to return to the original image.

 



Palette

A palette (table) is a list of colors used for image processing. The number of colors in a
palette depends on the intensity of the colors in the image. The intensity is determined
by the number of bits per pixel. In PixBuilder Studio, the normal mode requires eight
bits per each chromatic RGB channel and eight bits for providing the information about
the level of a pixel transparency (Alpha-channel).

Sometimes it is necessary to produce an image with a palette of a few colors. Each pixel
of such an image corresponds to an index, one for each color in a palette, which may
include up to 256 different colors. In fact, the fewer colors the palette has, the smaller
the size of the image file that we obtain. On the other hand, using very few colors can
spoil your image.

Full-color image and eight-color image.

By default, PixBuilder Studio uses a full-color RGBA palette. You can change the settings
of the palette by launching its configuration window from the user menu (Colors - Edit
Palette).



 

Settings list.

When you chose "Adaðtive" from the list of settings the program constructs the optimal
palette in order to reduce image distortion to a minimum. The dialog allows you to
change, add, and delete colors from the palette. Also there are options to upload and
save palettes.

After a palette is chosen every color in the image will be approximated by the color from
the palette.

In fact, the image will always be processed in RGBA mode, while the palette is used only



for displaying the image and saving it in a file.

If you choose a color in the dialog box that does not exist in the palette, an exclamation
mark will appear.

 



Submenu "File"

Submenu "File" includes the following:

New

Open

Open Recent

Close

Save

Save as

Save With Preview

Scan

Select Scanner

Print

File Info

Exit

Submenu File
 

Submenu "File"

Submenu "File" includes the following:

New

Open

Open Recent

Close

Save

Save as

Save With Preview

Scan

Select Scanner

Print

File Info

Exit

Submenu File
 



Create an image or an icon

To start a new image, click "File" -> "New" on the user menu.

Starting a new image. Bookmark "Image".

This is used to set the name, size, and color of an image. The size can be chosen
arbitrarily or from the templates. New sizes can be added to the templates as well.

If there is an image in the clipboard at the moment, the size of that image is used by
default.



Starting a new image. Bookmark "Icon".

This is used to create an icon.

The name and size of a new icon, as well as the color intensity, can be set here.

 



Open an image

To open an image, click "File" -> "Open" from the user menu. A standard window for
selecting image files (with a preview option) will appear.

The following file types are supported:

BMP (*.bmp; *.dib; *.rle),
PNG (*.png),
JPG (*.jpg; *.jpeg; *.jpe; *.jif; *.jfif),
GIF (*.gif),
TIFF (*.tif; *.tiff; *.xif),
PCX (*.pcx; *.dcx),
Targa (*.tga,)
Photoshop (*.psd),
Icons (*.ico),
PixBuilder Studio Files (*.pbs).

Submenu "Open Recent" shows the last 10 working files.

 



Save changes

PixBuilder Studio offers you three ways to save a file: Save, Save As, and Save With
Preview.

"Save" is only available if the image has been changed. The extension of the saved file
will remain the same. If the image is new, "Save" will operate as "Save As".

"Save As" offers the chance to choose the format of a file you want to obtain and set the
saving parameters.

"Save With Preview" is only available for images with resolution less than ten
megapixels. If the resolution is higher, "Save With Preview" will operate as "Save As".



"Save With Preview" dialog windows.
A - choosing the format
B - saving parameters
C - palette parameters
D - original image
E - destination image
F - the location button of original and destination images
G - choosing the scale

The dialog has a preview option.

 



Print an image

To print an image, click "File" -> "Print" on a user menu.

Printing an image.

The dialog is used for setting the size of an image and its location on a page, as well as
for choosing the printer, its properties, and the desired number of print copies.

 



Info about the file

General information about the file can be obtained by clicking "File" -> "File Info" on the
user menu.

 



Tools

To access PixBuilder Studio tools, you can use the user menus (for quick access), the
Selection submenu (for accessing the tools to work with selections), and the Tools
submenu (for accessing all other tools).

The tools in the Tools Panel are divided into three groups:

A - the tools for dealing with selections
B - the tools for drawing
C - the auxiliary tools

The Selection submenu
 



The Tools submenu

The following topics are available:

The tools for dealing with selections

The tools for drawing

The auxiliary tools

 



The tools for dealing with selections

Activate the required tool. When the mouse hovers above a selected area, a cursor

appears . In this case, the selection can be shifted. If at the same time you hold a

Ctrl key down, a cursor appears . In this case, the selection will be shifted together
with the selected area. When a Shift key is held down, a new selected area can be

added to the already existing one . When an Alt key is held down, a new selected

area can be subtracted from the already existing one .

The following tools are available for dealing with selections:

Rectangular Marquee. The Rectangular Marquee tool is used for selecting a
rectangular area.
Lasso. The Lasso tool is used for selecting an area of any shape.
Move Tool. To apply the tool, do one of the following:

1) Click on a selected area and drag the selection to a new position. If you have
multiple selections, all of them will move at the same time.

The original selection (left), and the selection moved with the Move tool (right)

2) Select the layer you want to move. Then drag the layer to a new position.

Magic Wand. The Magic Wand tool is used for selecting a consistently colored area
(for example, a red flower) without tracing its border. The color range and tolerance
have to be specified in order to use the tool. (Selecting an area using the Magic Wand
tool)
Elliptical Marquee. The Elliptical Marquee tool is used for selecting an elliptical
area.
Single Row Marquee. The Single Row Marquee tool is used for selecting a single
line.
Single Column Marquee. The Single Column Marquee tool is used for selecting a
single column.
Polygonal Lasso. The Polygonal Lasso tool is used for selecting a straight-edged
segment.

 



The tools for drawing

Drawing takes place on a selected layer. If several layers are selected, drawing takes
place on the layer placed highest on the Layers Panel. If the working layer does not
have a selected area, drawing is allowed on the entire layer. If there is a selected area,
the drawing is allowed only within this area.

To draw with the foreground color, hold down the left button of the mouse. To draw
with the background color, hold down the right button. To switch to the eyedropper,
hold the Alt button down and click on the image.

The following tools are available for drawing:

Brush tool. The Brush tool is used for drawing an image with a selected color. The
current color overlays the previous one.
Pencil tool. The Pencil tool is used for drawing an image with a selected color. The
process results in replacing the pixels of an old color with the pixels of a current
color.
Eraser tool. The Eraser tool is used for drawing an image with the transparent color.
Line tool. The Line tool is used for drawing a line on an image.
Color Fill tool. The Color Fill tool is used for filling the adjacent pixels of similar
color with the color of a selected pixel.(Color Fill)
Text tool. The Text tool is used for creating or editing a text layer. (Creating a text
layer)
Gradient tool. The Gradient tool is used for creating a gradual blend among multiple
colors. A gradient fill can be either created or chosen from presets. (Gradient Fill)
Replace Color tool. The Replace Color tool is used for changing the color of a pixel.
Clone Stamp. The Clone Stamp tool is used for taking a sample of an image for later
reuse on the same image.

 



The auxiliary tools

Eyedropper tool. The Eyedropper tool is used for changing a foreground or
background color from any open image.

To apply the Eyedropper tool, do the following:

On the Tools menu, choose the Eyedropper tool .1.
Place the cursor above the area of a color you want to change.2.
Left-click to change the foreground color or right-click to change the background
color.

3.

 

Measure tool. The Measure tool is used for precise positioning of images or elements

. It calculates the distance between any two points in the working area. When you
measure the distance between two points, a non-printing line is drawn, and the Tools
panel shows the following information:

a. The starting point (X1 and Y1)
b. The ending point (X2 and Y2)
c. The horizontal (W) and vertical (H) distances between the x and y axes
d. The total distance (L)
e. The angle measured with respect to the axis (A)

 

Hand tool. Do one of the following:

Use the window scroll bars.

Select the Hand tool  and drag to pan over the image.

A - group of layers,



Drag the colored box (proxy view area) in the Zoom panel.

To use the Hand tool while another tool is selected, hold down the spacebar as you drag
in the image.

 

Zoom tool. The Zoom tool is used for zooming in/out on an image. 

Tools panel.

Zoom in on an image by holding the A button. Zoom out by holding on the B button. To
change the size of an image to the actual size, press the Actual Pixels button. To change
the size of an image to the full screen size, press the Fit On Screen button.

 



Contacts

If you have access to the Internet, please visit our Web site. You can download the
newest versions of PixBuilder Studio as well as some other cool programs.
http://www.wnsoft.com

E-mail address for information, feedback, suggestions, bug reports, support etc:
http://www.wnsoft.com/support/

Thanks!
WnSoft Ltd.

http://www.wnsoft.com
http://www.wnsoft.com/support/

